Welcome, Guest
Username: Password: Remember me

TOPIC: Weak flow.

Weak flow. 6 months 3 weeks ago #72066

  • Oscarmon
  • Oscarmon's Avatar
  • OFFLINE
  • Apistogramma agassizii
  • Posts: 163
  • Thank you received: 6
  • Karma: 3
Hello everyone, this is my second post new subject of the day (see first above in index) and I was wondering whether my Marineland C-220 had something wrong with it.
It's flow has seemed quite weak over the past month and during a recent filter cleaning I was hoping the output rate would increase. Sadly, no. It hasn't changed. I'm unsure if this is a impeller problem and will possibly clean it next time. I'll post a picture possibly tomorrow of the weak output for you guys to check out.
The administrator has disabled public write access.

Weak flow. 6 months 3 weeks ago #72067

  • toom
  • toom's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 4491
  • Thank you received: 445
  • Karma: 15
1: Ceck the hose. Maybe it's clogged

2: Check if all the baskets and Foam pieces are correctly in place.

3: Clean impeller and shaft.

If this the case and it's still low on flow. Put out the baskets and check if the flow gets stronger if the canister is empty.
If this is the case it's possible the pumphead is not working correctly. In this case you have to contact the Support.
We need to stop talking about the people as if they were the crown of creation.
The administrator has disabled public write access.
Moderators: sprout, ~rush~, screwsloose
Time to create page: 0.093 seconds
Powered by Kunena Forum